How to Mine Bitcoins on Your Raspberry Pi

20
SHARE

0
0
0
0
0
0
0
0
0

Commands used in this video:

apt-get install gcc gcc-4.5 g++ g++-4.5 libstdc++6-4.5-dev libpcre3-dev libcurl3-dev make less

apt-get install ia32-libs ia32-libs-gtk lib32gcc1 lib32stdc++6 lib32z1 libc6-i386

mkdir bitcoind

cd bitcoind

wget http://yyz.us/bitcoin/cpuminer-1.0.2.tar.gz

tar -zxvf cpuminer-1.0.2.tar.gz

cd cpuminer-1.0.2

./configure

make

./minerd –url http://yourpool.x:8332 –userpass yourusername:yourpassword

Please Note this will work on any hardware. I have successfully compiled this on a PowerPc mac and PowerPc linux.

20 COMMENTS

  1. I am hoping to upgrade this video so I can use the latest cpuminer software. Can you help me? Can we communicate via email? The latest cpuminer appears to be something like cpuminer-2.4.1.tar.gz. Please let me know.

  2. Which repositories have you included? Because when i run "sudo apt-get install ia32-libs ia32-libs-gtk lib32gcc1 lib32stdc++6 lib32z1 libc6-i386" I get errors saying that the packages cannot be found.

  3. I don't have direct experience of this but I believe these devices are used by the mining program on your PC to do the crunching in a similar way to how these programs use the GPU. Such a program could be run on a PI which would use the attached USB device to crunch. A butterfly does not have Internet connection but a PI or a PC does.

  4. whenevre i try that second row of that command i get
    Reading state information… Done
    E: Unable to locate package ia32-libs
    E: Unable to locate package ia32-libs-gtk
    E: Unable to locate package lib32gcc1
    E: Unable to locate package lib32stdc++6
    E: Couldn't find any package by regex 'lib32stdc++6'
    E: Unable to locate package lib32z1
    E: Unable to locate package libc6-i386

    what can i do about this ???

  5. sudo apt-get install bitcoind
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    bitcoind is already the newest version.
    0 upgraded, 0 newly installed, 0 to remove and 171 not upgraded.

  6. Are you sure this exists in raspbian?

    apt-get install bitcoind
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    E: Unable to locate package bitcoind

LEAVE A REPLY